Heartbleed vulnerability update

In light of the recently identified Heartbleed vulnerability in the popular OpenSSL cryptographic software library, Scholars Portal has undertaken an investigation of its applications and infrastructure.

As a result it identified that the majority of Scholars Portal services as well as the OCUL website and SPOTdocs wiki were not affected by or do not use the vulnerable OpenSSL.
 
The security risk to the services that were affected is considered very low. However, as an extra precaution, on discovering this vulnerability Scholars Portal took immediate action to secure its services. These vulnerabilities were fixed on Tuesday 8th April, 2014. Services affected include:

  • Ontario Usage Rights (OUR) Database
  • Open Journals System (OJS)

The Scholars Portal Systems Team continue to work hard to ensure the ongoing security of Scholars Portal services.
 
If you have any questions please contact help [at] scholarsportal.info.